OSX El Capitan - Issues, fonts, yada yada yada

  • Started
  • Last post
  • 21 Responses
  • VectorMasked

    Anybody here has experienced any annoying issues with El Capitan and your usual software?

    I upgraded to El Capitan a couple of days ago. Everything has been sorta ok, but now that I have to get back to the computer to work after a little break I'm experiencing to annoying problems. Gmail was useless at first but after updating tje java plugin it's back to normal.

    First, my Word and Excel programs won't launch. Fortunately I was able to open the doc in Preview to extract the client's content.

    The biggest issue is with fonts. I'm using FontExplorer X Pro. Zero issues until now. Not seeing any fonts activated in any programs although they are activated, just the basic system fonts show up in InDesign, etc... And just now after this font issue with Font Explorer, went for the lastest update and still can't get the fonts to show up or work outside Font Explorer.

    I'm doing research to see what the issue is, but I am posting here to see if any of you could have suggestions to find a solution asap. I'm supposed to be working right now on some material for a client that will be at the NAMM show.

    Macboo Pro 15 (retina), Font Explorer X Pro (latest update), Creative Suite 6 (don't want to upgrade).

  • VectorMasked0

    Well after over an hour of struggling over here, I quit Skype and managed to get Word and Excel open.

    Still no luck with Font Explorer and fonts showing up in Indesign and stuff. Any suggestions for font management that will work on El Capitan and CS6?

  • omg1

    Mail has never been the same since el Capitan. I've tried two other email programs that aren't much of an improvement.

  • Gnash0

    Try the solution below. Even though it's a Suitcase resolution some people have had luck with it fixing the Fontx problem.


  • autoflavour1

    i have a few issues..

    first is if i put the machine to sleep or shut it down, it never actually completes it.. it just sits there.

    i have been getting beachballing, but unlike ever other OS before, switching to FORCE QUIT doesnt seem to work, only to then beachballing there too..

    the weirdest one is i will be working then all of a sudden out of now where it just restarts. the log says cpu panic, but this machine has been running fine up until this upgrade..

    i dont want to go back as its just a huge ball ache..
    but yep, this os feels unstable at best.

    • Sounds like a hardware issue. 3rd party memory added?monospaced
    • Most kernel panics and random acts like that are due to failing Hardware. Not just macs.monospaced
    • 3rd party ram, but its kingston and its been in there for the last 3 years without a fault.
      only since El Capitan has it started.
    • the same happens to me...dmay
    • Still.monospaced
    • hackingtosh?mugwart
  • i_monk2

    Note to self: Still too early to upgrade to El C.

    • yup. especially with lots of legacy software.Gnash
  • VectorMasked0

    Font Explorer is back to normal now for no apparent reason.

    Been drinking my latte while surfing the web for solutions and all of the sudden Galaxie Polaris shows up in inDesign.

    One thing that is driving me nuts is the issue with the scrollbar in Preview though. Open up multiples images and shit, like let's say 20 at once to browse thru them and shit scrollbar is just there as if there were only 3 images opened. Gotta either resize the preview window a few times or just use the up and down keys.

  • MrT0

    I wonder if Apple secretly want everyone to buy a new machine along with each new OS. Feels like that with iOS...

    • I dunno. Their backward compatibility is actually some of the best, but perhaps that's changing. I can see it starting with the closed computer cases.monospaced
  • hans_glib1

    i blame the fucking devs.

    as processor speeds increase and ram gets cheaper, they find something to do with the extra power, regardless of whether or not it's an improvement for the user.

    cunts, the lot of them

  • monoboy0

    Every upgrade is optimised for the latest hardware so little point in upgrading if your equipment is more than two years old.

    All you'll get are 'features' you've lived happily without and reduced performance.

    I think MrT is right. Apple knowingly push upgrades on devices that aren't really able to run it well so you upgrade. My iPad mini now runs like snoop dog.

    Ignore the marketing pish, stick with the OS that was released when your machine was.

    • not feasible, because there are apps that simply start to ignore older OS versions, so you need to upgrade the OS to use your apps..ESKEMA
    • Don't upgrade your apps.monoboy
    • Face palm*bklyndroobeki
  • oey0

    The Calendar still not working...
    Adding remote Address Book (in server) to Contacts not working...

    Whatever, just keep on using Thunderbird with SoGo Connector and Lightning.

    But activating fonts in Linotype FontExplorer X is being a serious issue by now after trying it for the last 3 days.

    Can not do anything and it's really fucking annoying.
    Tried to move the FontExplorer folder to other location and still nothing.

    So far didn't notice any other issues and if I find a way to solve the font issue I'll be very happy.

  • oey0

    Okay, or not okay...

    FontExplorer has the deactivate option when quitting the Program.
    But even with that option not checked...what happens is that when I shut down the computer, or restart, all activated fonts will be deactivated.

    When I close the program and open it during a session without logging out fonts are still activated.

    I don't have FontBook installed in case you're wondering.

    I'm considering in buying FontExplorer's latest version though I'm not doing any professional work right now but I have doubts if the problem will persist or not...

    I'm right now redesigning my website and selcting work for a fresh portfolio and would like to work on some stuff to print it and make some photos of my work but it's a pain in the ass to have to activate all the fonts all the time or to make a folder for each project now.

    The computer already came with El Capitan installed...

    • You should have font book installed. It's system software and I'm not sure it's easily removed without serious issues.monospaced
    • i always read you shouldn't have them both installed because of conflicts. and also i have uninstalled system software since my first mac without problems.oey
    • but thanks for your advice mono!
    • You shouldn't have both Font Book and FontExplorer X (or any other font manager) *running* at the same time. FontExplorer X warns if this is the case.evilpeacock
    • And you should update to the latest FontExplorer when dealing with new operating systems. 5.5 just released with mostly bug fixes and improved OS support.evilpeacock
    • I don't have both installed, only FontExplorer X. Yes, I should update it but I was trying to save some money since I'm not doing any professional work now.oey
    • I know what you mean and I fully agree.oey
    • I'm having the same issues with FontEx even though I'm not in elCap. known issues. I have found a few fixes that work for a while - I'll dig them upGnash
  • shaft0

    FontExplorerX — have you tried closing it down after it started on launch, then running it again? That's what older versions of it required on mine for the last 2 years or so.

  • Gnash0

    A potential FontExplorer fix:

    1. Locate "FontExplorer X Pro.app" in Applications
    2. Right-click on "FontExplorer X Pro.app" and select "Show Package Contents"
    3. Navigate to /Contents/Helpers/
    4. Double-click "FontExplorerXLauncher-3.app" or right-click and "Open" to launch it manually. This is needed only once, afterwards the plugins will work normally.

    make sure you open the version with the "-3" suffix, the other one does not fix the problem.

    • it resolved the auto-activation issue for me.Gnash
    • I don't have the /Contents/Helpers/ folderoey
    • you have to, oey. right-click the app icon, that opens a folder with the contents of the app itself. it's not a loose folder that's visible.Gnash
    • I know what you mean, totally. but I really don't have it :/oey
    • I have the file "FontExplorerXLaunch... inside the Resources folder. That's it.oey
    • see belowGnash
  • bklyndroobeki0

    Installed El Capitan on an older MacBook (2011) I knew It would be trouble.

    It says that it cannot install (errors in a .txt) but I just keep going thru the loop of installs-- anyway to easily abort this? It won't allow me to do much else.

    • https://discussions.…Gnash
    • I have a feeling I'm about to lose everything. Will try this but I suck at this kind of stuff. Wish me luck. Tx Gnash :|bklyndroobeki
    • take it slow. do you have a time machine b/u?Gnash
    • No, no Timemachine- I've even mainly using Dropbox to backup but Not thorough. do you think my HD will have to be re formatted?bklyndroobeki
    • reformatting is a good idea but not mandatory -- you lose all your data, though. Try and save what you can first.Gnash
    • there were a few strategies for doing that in the thread i linkedGnash
    • if the data isn't that critical then reformatting is a good idea.Gnash
    • keep in mind that some legacy software can't be installed onto ElCap, like versions lower than Creative Suite CS6Gnash
    • I'd so prefer not to loose my work-- getting an error though. Going to search a bit more though this link is really useful http://imgur.com/ZNn…bklyndroobeki
    • sucks! don't give up though. ya, lots more resources on line. It may be worth taking it somewhere to grab the data.Gnash
    • I gave up. Overwhelmed mostly. Going to put the computer to rest & take a walk... You help was gold; going to come back to it in a couple daysbklyndroobeki
    • good idea :)Gnash
    • you gotta be zen to navigate this stuff (or give it to someone else to do)Gnash
    • Newer versions of OSX install a recovery disk partition with tools to help you recover data etc. Get hold of an older install dvd and run the tools from that?face_melter
    • Or, take the drive out, place in a caddy and get your data that way. If it's a 2011, the drive should be easy to remove.face_melter
    • No luck. In fact managed to make things worse.bklyndroobeki
    • does anything come up when you do a 'safe start'?Gnash
    • Gnash, I almost bashed it in yesterday... I was close and held myself back. I guess that could happen when in terminal for 10+ hoursbklyndroobeki
    • I took it to the G.bar today. They did miracle work. I wiped my machine yesterday after giving up. Lesson learned, actually happy to have a clean slate.bklyndroobeki
    • peace be with you, brother. and hook up that Time Machine!Gnash
    • LOL I'm on it tonight. man thanks for keeping me zen.bklyndroobeki
  • ernexbcn1

    Had it since it was released at home but never used Apple Mail there. Installed El Capitan @ work upgrading from Mavericks and Apple Mail has turned into complete shit, it's slow/unresponsive.

    Apple pls.

  • CyBrainX1

    I don't use Font Explorer anymore but have upgraded two Macs at home and haven't had any issues. I have CC2015 and Cinema 4D and a ton of video utilities and other miscellany. All good at work too on a new Mac Pro.

  • Gnash0

    @bklyndroobeki - give this a try. "safe" mode may allow you to grab your files

  • oey0


  • Gnash0

    - go the to actual app itself (in the applications folder).

    - find the icon for the app (not a folder the app itself).

    - Right-click the app (or control-click) to get a new dialog box

    - the second item in the list is "show package contents," select this.

    you can't find the folder by searching, it's hidden within the app itself.

    • Yes, I did exactly that and the folders I have are: Frameworks, Library, MacOS and Resources. In any of these folders there's any Help folder.oey
    • Except for the "FontExplorerXHelp" folder inside the English.Iproj folder inside of the Resources folder.oey
    • damn, oey. not sure what to suggest. i have version 4.2.3 of FontEx pro -- you?Gnash
    • ups! amateur i am...1.2.3oey
  • oey0

    RightFont anyone?

    I really need a Font Manager and Suitcase and Linotype are bit pricey for me right now.

    RightFont costs the half of the price...
    Still I would prefer other option if I could.